Why is Google warning us only now?

Home / ZEFO's Posts / News and updates from the web / Why is Google warning us only now?

Hey guys,

It’s a known fact that Google is a market leader, producing only the best innovations to hit the market, setting the tone for indexing, dominating the markets in terms of search and more.

But what happens when even such a giant sends outdated warnings?

This has happened a week ago, with WordPress and Joomla users receiving warnings that their software is outdated, when new updates by WordPress and Joomla had already hit the markets months before.

The tags that were generated also seemed outdated, based on the Google Index’s old cache that the tags originated from, which raised a major concern around the WordPress and Joomla communities.

The first question that arose by the community was “why are we only knowing this now?” which sent hundreds of programmers to start checking their websites to see what seems to be the problem, how it affects search and how long has it been affected until Google released these tags.

Some thought that this warning was based on the REST API Vulnerability that was introduced in WordPress 4.7 and created mass defacements among WordPress websites.

Even if you are certain that your site is up to date, it wouldn’t hurt to check that everything is in accordance with your own standards, albeit being version 7.1 already on WordPress.

Some voices in the community had actually applauded Google, and said that perhaps Google had concerns before but only now realized the magnitude of such a problem and only now issued these warnings to WordPress and Joomla users.

Whatever the case is, if you haven’t already, check your website – see that it looks the way it should look, make sure you are still visible on search results, look for the discrepancies.

WordPress Notice

A copy of the WordPress notice is set out below:

Google has detected that your site is currently running WordPress 4.7.0 or 4.7.1, an older version of WordPress. Outdated or unpatched software can be vulnerable to hacking and malware exploits that harm potential visitors to your site. Therefore, we suggest you update the software on your site as soon as possible.

The notice then proceeds to set out some example URLS, and make some recommended actions:

  • Update to the latest release of WordPress
  • Check your site for hacked content
  • Stay up to date on new releases

Joomla Notice

A copy of the Joomla notice is set out below:

Google has detected that your site is currently running Joomla 1.5, an older version of Joomla. Outdated or unpatched software can be vulnerable to hacking and malware exploits that harm potential visitors to your site. Therefore, we suggest you update the software on your site as soon as possible.

Again, similar recommendations were made at the end of the notice.

Google is a huge company, it makes mistakes, but it’s here to mend these as well.

Leave a Reply

Your email address will not be published. Required fields are marked *